Unable to add images

Discussion in 'Help and Rules' started by TheReal_McChicken, Apr 21, 2019.

  1. TheReal_McChicken Active Member

    Joined:
    Mar 22, 2019
    Location:
    Canada
    As on the tin, I am unable to upload pictures to my posts. I have tried 4 different image hosting websites and each time the picture appears as a little icon of a photo with a big red X over it. Has anyone had this problem and does anyone know how I can fix it?
     
  2. Eldy If you try sometimes

    Joined:
    Oct 4, 2010
    Location:
    Maryland
    You need to use the direct URL of the image itself, not a page which displays it. For example, in this post, you used the URL of the Imgur album page:

    https://imgur.com/a/hooJuJZ

    On the Imgur page, though, if you right-click the image (press and hold on mobile) and select "open image in new tab" or whatever the phrasing is in your browser, you'll see that the URL for the image itself is:

    https://i.imgur.com/89LSLPW.jpg

    You can also get this by right-clicking and selecting "copy image address" or, again, whatever equivalent your browser might have. When you slap that URL between IMG tags, the image should display properly.

    Code:
    [IMG]https://i.imgur.com/89LSLPW.jpg[/IMG]
    [​IMG]

    Hope this helps! :)
     
    Zagan likes this.
  3. TheReal_McChicken Active Member

    Joined:
    Mar 22, 2019
    Location:
    Canada
    @Eldy thank you very much. I can't believe it was something so simple.
     
    Eldy likes this.